[grsec] grsec patch for 2.6.15?

Dan Hollis reg5423374856 at anime.net
Mon Jan 9 15:17:00 EST 2006

On Mon, 9 Jan 2006, pageexec at freemail.hu wrote:
> On 9 Jan 2006 at 12:57, Carlos Carvalho wrote:
>> Is there an expected release date for the 2.6.15 version? I tried to
>> use the latest one from ~spender but there are too many rejects that I
>> don't know how to fix...
> most likely i'll skip .15.
>> 2.6.15 contains numerous fixes and enhancements for server features
>> that make it worth upgrading. It'll be my first try on a critical
>> server that's running 2.4.32.
> what i said about 2.6 security a while ago still applies, all the more
> as it proved true time and again.
> http://forums.grsecurity.net/viewtopic.php?t=968

Unfortunately 2.4.x doesn't support my hardware at all, so 2.4 is no 

This attitude toward kernel security is very curious; if your assertion is 
true than surely 2.6 is needing pax more than anything. So the choice to 
deliberately skip supporting it is strange.

It's a tactic I might expect from microsoft or maybe theo de raadt, it's 
suprising to see it here.


More information about the grsecurity mailing list